RSS
 

Windows 7 Installation hängt

13 Apr

Nachdem Windows XP am 8. April 2014 (glücklicherweise) endlich von Microsoft fallengelassen worden ist und – bis auf ein paar finanzstarke Ausnahmen – der Support sowie Sicherheitsupdates eingestellt wurden, war es an der Zeit meinen Gaming PC von Windows XP auf Windows 7 zu aktualisieren.

Vorgegangen bin ich wie bei meinem Dell Inspiron 1525 vor 4 Monaten. Allerdings zeigt das Windows 7 Setup nach dem ersten Neustart die Fehlermeldung

Windows kann nicht für die Ausführung auf der Hardware dieses Computers konfiguriert werden

Damit begann eine lange Odyssee der Fehlersuche.

Zuerst dachte ich, dass ich auf dem AMD Athlon 64 X2 Prozessor kein 64bit Windows installieren kann (auch wenn das Internet etwas anderes behauptet). Schliesslich lässt die Fehlermeldung auf ein Problem in der Richtung schliessen. Allerdings erscheint bei der Installation der 32bit Variante die gleiche Fehlermeldung.

Nächste Vermutung: Die Kingston V+ SNVP325-S2 SSD benötigt einen speziellen Treiber. Allerdings ist auf der Support Website von Kingston kein derartiger Treiber zu finden. Das gleiche gilt für eine aktualisierte Firmware für die SSD.

Als nächstes hatte ich die Vermutung, dass das Windows 7 Setup sich selbst ein Bein stellt und beim formatieren der SSD etwas falsch macht. Aber auch ein „vor“-Formatieren der SSD auf einem anderen System brachte keinen Erfolg.

Um auszuschliessen, dass es an der SSD liegt, habe ich – ohne Erfolg – eine Installation auf einer herkömmlichen HDD versucht.

Nächster Versuch: Installation mit geänderter „Onboard SATA Type“ Einstellung im BIOS. Das Internet empfiehlt zwar, dass bei einer Windows 7 Installation der Wert auf „AHCI Controller“ gesetzt sein sollte, aber ein Versuch mit „IDE Controller“ kann nicht schaden (dachte ich mir). Dieser hat aber leider keinen Erfolg gebracht.

Weiters habe ich die Grafikkarte ausgebaut um einen Fehler in dem Bereich auszuschliessen sowie jeden einzelnen der 4 1GB Arbeitsspeicher-Riegel als Fehlerquelle ausgeschlossen. Ohne Erfolg.

Als nächstes versuchte ich diesem Hinweis von Microsoft nachzugehen um den Grund der Fehlermeldung zu eruieren („How do I know if I have this issue?“). Allerdings war auf meinem System kein Ordner mit dem Namen %systemroot%\Panther vorhanden.

Ab und zu lieferte das Windows 7 Setup nicht die oben genannte Fehlermeldung sondern blieb einfach beim Schritt „Die Installation wird abgeschlossen …“ hängen, was die Fehler-Ursachen-Suche nicht einfacher gemacht hat.

Etwa 10 unfertige Windows 7 Installationen später bin ich über diesen Eintrag von Ralph Lehmann gestolpert und – ich schäme mich dafür – das hat das Problem gelöst (Zitat):

  • […]
  • Verhindern Sie den Neustart, indem Sie den Rechner ausschalten, nachdem Windows heruntergefahren wurde, aber bevor es neu gestartet wird.
  • Entfernen Sie alle USB-Geräte einschließlich Tastatur und Maus.
  • Starten Sie den Computer erneut und warten Sie, bis die Installation abgeschlossen ist.
  • […]

Ich habe Ähnliches schon 100 Mal gelesen und auch beachtet. Aber dieses eine Mal habe ich nicht daran gedacht und einfach die zweite Maus, den Drucker, die USB-Hubs der Bildschirme und das USB-Headset am Rechner hängen lassen.

Kaum zu glauben, dass das Windows 7 Setup sich durch solche Geräte irritieren lässt und noch schlimmer, dass die Fehlermeldung überhaupt nicht darauf schliessen lässt.

Fazit: Wieder etwas gelernt (positiv) und fast einen kompletten Freitag damit verbracht (negativ).

 
8 Kommentare

Gepostet in Computer

 

Kommentare

 

 
  1. Madde

    21/12/2014 17:05

    Also ich muss jetzt mal einen Kommentar dalassen. Ich komme zwar nicht direkt aus der IT-Branche, bin aber in selbiger ganz gut unterwegs. Dachte ich jedenfalls bis heute. Ich habe den ganzen Tag damit verbracht Lösungen für das hier genannte Problem zu finden, von Treiberinstallationen bis hin zu Einstellungen im BIOS (AHCI). Nichts brachte Erfolg. Dann komme ich zu diesem Beitrag hier und denke mir so, na gut, testen, wobei ich dazu sagen muss, dass ich kurz nach dem Neustart den Stick gezogen habe, allerdings hatte er eben schon geblinkt, was den Schluss zulässt, dass bereits irgendwas geladen wurde.
    Lange Rede, kurzer Sinn.
    Jetzt hat es funktioniert.
    Ich danke für diesen Hinweis, er hat meinen Tag gerettet.

    Beste Grüße

    Madde

     
  2. jule_

    26/12/2014 19:49

    Hoi Madde,

    freut mich, dass dir mein Beitrag helfen konnte!

     
  3. Thark

    19/04/2016 21:22

    Hmm… Auch wenn es schon ein wenig älter ist ..
    So habe ich nun seit gestern derartige Probleme mit meinem Laptop …
    Windows 7 x64 habe ich von Anfang an laufen lassen, zwischenzeitlich per USB Drive neu installiert.

    Nur heute streikt es auf einmal ohne weiteres..
    Ich bin schon am verzweifeln .. es ging bisher immer ohne weiteren Probleme (mit eingestecktem USB Drive)
    Einmal erkannte der Lappy kein USB-Stick mehr hmm… Windows über’ne DVD installiert, BIOS aktualisiert und dann wars das auch.

    Wie auch immer … Werde mich morgen direkt nochmal daran setzen und es probieren, wahrscheinlich wirds es auch klappen …

    Es ist schon eigenartig … bei Microsoft arbeiten so viele qualifizierte Leute und es hapert dann an solch kleinigkeiten.
    Je mehr ich Linux nutze umso mehr schätze ich es. Man ist mit Windows nur an zig ristriktionen gebunden. :/
    Linux ist nicht einfach – Das ist die Kehrseite. Aber es ist viel mehr machbar out of the box.

    Nur um mal kleinigkeiten zu nennen: Partitionieren (GParted) vor allem USB-Sticks (Ja, auch wenns niemand braucht, so ist es aber ungemein schöner, wenn man es kann ;))
    Die Installationsroutine – Oh obvious!
    Eigene Dateien ist mit /home schnell umgesiedelt. Was sich unter Windows ein bisschen schwieriger gestaltet

    Ich will Windows nicht schlecht reden – Aber mit dem Einsatz von beiden, Linux und Windows, fallen halt beidseitig viele schwächen auf. Bei Linux muss man unter Umständen verdammt viel per Hand umschreiben, was Nerven kosten wird. Zumal es auch unglaublich komplex ist.

    Entschuldige für diesen Text of Wall … ^^“

     
    • jule_

      19/04/2016 21:55

      Hi Thark,

      danke für deinen Kommentar. Ich drück‘ dir die Daumen, dass es morgen funktioniert.

      Ohne, dass ich mich jetzt als Fanboy von einem der drei „Lager“ deklarieren möchte, bin ich doch recht froh, dass ich mich schon vor einigen Jahren getraut habe auf OS X zu wechseln. Es vereint das „it just works“ GUI mit der Möglichkeit eines vollständigen UNIX Unterbaus.

      Wobei ich zugeben muss, dass man auch mit OS X an die ein oder andere Grenze stossen kann.

       
  4. Helmut

    06/08/2017 11:10

    UNGLAUBLICH
    UNFASSBAR!

    Ich habe jetzt sicher zehn Installationsversuche hinter mir und alles probiert. Die Win10-Installation ist immer nach den 100% beim nächsten Reboot weggewesen und nur das Fenster mit der Meldung „konnte nicht installiert werden“ im wiederhergestellten Win7 blieb übrig.

    Auch die Analyse der setuperr.log brachte keine Ergebnisse.

    Völlig nutzlos waren alle supertollen Vorschläge der MS-zertifizierten Schreiber in den Supportforen.

    In meiner Not habe ich schließlich versucht die vorhandene Win7pro auf W7Ultimate upzugraden.
    Auch diese Installation lief wie alle davor reibungslos, bis am Ende nach dem Neustart wenigstens folgende Meldung angezeigt wurde:

    Windows kann nicht für die Ausführung auf der Hardware dieses Computers konfiguriert werden

    Mit dieser Fehlermeöldung lieferte Google u.a. einen Foreneintrag in drwindows.de: und in Beitrag #15 macht ein Nutzer „Terrier“ auf diesen Blogartikel aufmerksam:
    Hast Du alle USB-Gerät abgesteckt?

    So ein SCHWACHSINN, dachte ich mir (dank ET-Studium mit Zweig Computertechnik…).
    Als ich dann hier die Kommetnare las, fand ich es nicht mehr so schwachsinnig und leise Hoffnung keimte auf – die Hoffnung stirbt ja zuletzt.

    Also hab ich, als dieser violette Installationsschirm bei etwa 25% stand, den bootfähigen USB-Stick, das einzige USB-Gerät am Schleppi, abgezogen.
    Und alles lief zu Ende wie es sollte, Gerät rebootete und der hellblaue Bildschirm mit der „Vorbereitung der Updates“ erschien und W10 wurde absolut problemlos installiert…

    Was soll man dazu noch sagen?

    Von mir ein RIESEN DANKE für diesen Artikel!